HowNow X - Learning & Support

Records - Adding Documents

The types of documents added to Records usually relate to clients, such as letters sent to clients, completed checklists, and completed workpapers, etc. But can also be for employee or firm related documents such as HR, administration, finance, etc.


Documents can be added to HowNow manually via Drag and Drop, by using the Right-click menu, using copy and paste, using the Office Add-ins, automatically from knowledge templates or merge documents, duplicating and scanning. Each of these ways of adding files to records is explained up to the point of the New Profile Wizard - from that point the steps detailed here.


HowNow New Profile Wizard

After the HowNow New Profile Wizard appears, follow these steps:

  • Choose Records (adding Knowledge documents is covered separately) from the Add File To section
  • If the Workflow module is installed the first selection under destination is to enter the Job - you can search for the job and once selected, the contact (if applicable) will be prefilled. 
  • In the Area field, choose the appropriate area to save the record. For example, choose a Contacts, Team or Admin area. Note: the names of these areas will reflect the set-up of your firm's record locations.

Note: When an email is added to HowNow, an attempt is made to automatically find the appropriate contact via the email address or domain. If the firm has set-up excluded email domains such as @gmail.com or @bigpond.com they will be excluded from this process.

Note: When a file is added to HowNow, an attempt is made to automatically find the appropriate contact by assuming that the first word of the filename is the client 's code.

  • If Contacts or Teams was chosen above, select a contact or person from the drop-down list.
  • Choose the Location of the record(s).
  • If Record Linking is enabled, optionally enter a link code.
  • Click Next for the New Profile Wizard - Records profile information.
  • Enter the record Title or select a suitable title from the drop-down list of standard record titles.
  • Optionally enter the record Description and any additional keywords.
  • Optionally set the Employee Roles - select a Partner, Manager, Reviewer, Preparer and Signatory. These will default in order as follows:
    • The details on the contacts tab for that client - if this is not available,
    • The employee defaults as set-up in the employee's profile - if this is not available,
    • The last selections that were chosen by the user.
  • The default record status is Draft. To change this, select a different status from the drop-down list.
  • Optionally, select Assign a task for this record to create a follow up task on completion of adding the record.
  • The file will be moved into the HowNow Records database, if you don't wish to move the file select Copy in the File Operation area.
  • Click Next for Record Visibility - if the document is confidential or only to be made available to certain Teams select the relevant teams. Teams can only be selected by members who belong to that team/s.
  • Select Finish to complete the process of adding the document to Records.


Adding Documents via Drag and Drop

Select one or more files from Windows Explorer and click on the selected files, hold down the left mouse button and drag the documents over the HowNow icon on the start or task bar but do not release the left button. This can also be achieved from an attached file in a MS Outlook email. When the HowNow main screen appears, move the cursor to the middle of the screen and release the left mouse button. The New Profile Wizard will appear - follow the steps outlined above. 


Adding Documents via Copy and Paste

Copy a document from a location on your computer or from Knowledge, click anywhere on the records grid and press Ctrl+V, or select paste from the right-click menu. The New Profile Wizard will appear - follow the steps outlined above.


If the incoming file appears to be a data file (for example, one with an extension of .myo, .dat, .qbw or .zip) HowNow will ask if you want the file converted to a Data Record. If you answer yes, the Import Wizard will appear.


Adding Documents via Right-Click Menu

From the right-click menu, you can choose to add a New document - in this case you can browse to the selected document and then click Open. You will then be presented with the New Profile Wizard - follow the steps outlined above. You can also duplicate, add a file note or paste a document from the clipboard from this menu. 


Adding via Templates in Knowledge (Merge Documents or Documents set to Automatically File)

When using Knowledge some files are flagged as merge documents or automatically file. When opening these types of documents you will be presented with the Merge Document or Filing Wizard - for these documents, you will have additional screens to complete, but they are similar to the New Profile Wizard. See Running Merge Documents for further details about the information required for merge documents.


Adding Documents via Microsoft Office Add-ins

The Office Add-in is a toolbar available in Microsoft Word and Excel which allows documents, which were created outside of HowNow to be saved to HowNow. The Office Add-in can be installed from File > System Tools > General > HowNow Add-in Manager


After pressing the Add to HowNow icon, your will be asked to confirm the import of the document and then be shown the New Profile Wizard - follow the steps outlined above.


Once the document has been saved into HowNow, it will be reopened to enable further editing - the document has now become a document filed inside of HowNow.


If your Office Add-in needs updating you will receive a message to update the add-in.


Adding Documents via Microsoft Outlook

The HowNow Email Manager is an Add-in for Microsoft Outlook that provides an easy way to Add emails to HowNow by prompting users to save emails on Sending and Deleting emails.

By default the HowNow Email Manager adds the following to the Microsoft Outlook window:

  • a HowNow Add button in the Ribbon  
  • the HowNow menu option under File in the Outlook menu bar
  • a HowNow folder under the Inbox of Outlook, which will have Sent and Received sub-folders


The HowNow Email Manager also adds the Add to HowNow button on the ribbon of each Outlook Message window.

The Email Manager Add-in can be installed from File > System Tools > General > HowNow Add-in Manager


Email Manager will prompt you to save your email into HowNow each time you send or delete an email. The email will be saved with attachments included as part of the email. Attachments can be saved to HowNow independently.


Adding Documents by Duplicating

Duplicating creates an exact duplicate of the selected record. Right-click the record in the search results list and select Duplicate. The Duplicate Record dialog appears. Change any or all of the fields and click OK to create the duplicate record or Cancel to exit without creating a duplicate.


Adding Documents via Scanning

HowNow can receive scanned documents and records either directly from a scanner or via email or from a watch folder.

  • Scanner Direct: Most scanning software allows a Send To button to be created. In the field that asks for the application to send to, enter the path to the HowNow.exe file.
  • Scan to Email: If the scanner creates email, they can be either automatically captured by the Email Manager or by dragging and dropping them into HowNow.
  • Scan to Folder: If the scanner can save to a folder, HowNow can automatically monitor and capture files added to that folder. Folder monitoring must be enabled in Options and Employees.

In all cases above, the New Profile Wizard will appear and you can follow the steps outlined above.


File Notes

File Notes can be created and automatically filed as a Client Record text file. The text file contains the date and time of creation of the File Note, the elapsed time, the contact details, the Preparer details, and the File Note title and details.


Files notes can be minimised to enable using other areas of HowNow or to create an additional file note while still working on the original file note. These can then be maximised, finalised and saved. If a file note is still open when closing HowNow, you will be prompted to save the File Note. A File Note can be created by right-clicking the Records (or Contacts) search results list and choosing File Note from the menu or by pressing F9 anywhere in HowNow.

  • The Contact and Location will be pre-populated, but can be changed if needed.
  • Title – the title of the file note becomes the name of the resulting record. A standard title can also be selected from the drop-down list.
  • Link - Optionally select a link code for this record.
  • Note – the text of the note. Note: use F3 to insert today's date and time into the text.
  • Timer – automatically records the time the file note dialog is open. Click the Stop button to stop the timer. The Stop button will change to Start to allow the timer to be started again.
  • Partner, Manager, Reviewer – select the appropriate people in these roles for this file note.
  • Status – set to Final by default but it can be changed if necessary.


Record Note

A record note is a small amount of text pertaining to the record. Right-click on a record in the search screen and select Add a Record Note or press F8. The note is automatically populated with the date, time and employee's initials. Add the details to the note. This information is stored against the profile of the record, there is no document created. Press OK or Cancel.

If a record has a note against it an icon will appear on the search results screen and it can be hovered over with the mouse and the note will be shown. Note: If the first line of the note is blank, the note icon will not show.


Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.